1. Ana Sayfa
  2. Network
  3. Routing Information Protocol (RIP)

Routing Information Protocol (RIP)

rip

Routing  Information Protocol (RIP) bir distance –vector routing protokolüdür. Distance-vector routerlar routing tablolarının tamamını komşu routelara gönderir böylelikle router komuşularından aldığı routing bilgileri ile kendi bilgilerini birleştirerek routing tablosunu oluşturur.Network protokolü olarak rip kullanılan bir networkte her 30 saniyede bir routerlar  routing tablosunun tamamını tüm aktif interfacelere gönderir.Rip en iyi yolu hesaplamak için hop sayısına bakar ve maksimum geçilebelecek hop sayısı 15 dir bundan dolayı küçük networkler için rip kullanışlı bir protokol iken büyük networklerde ve wan yapısında yetersiz kalmaktadır. Rip version 1 ve version 2 olmak üzere ikiye ayrılıyor Rip version 1 ‘i  tercih ederseniz  version 1 classfull dur yani networkte  ki tüm cihazlar aynı subnet’e sahip olmak durumundadır.Version 2 ise classless dır yani route güncellemeleriyle beraber subnet masklarıda gönderir ve aynı zamanda prefix routing sağlar.Rip’in administartive distance numarası ise 120 dir.

Rip konfigürasyonu

Şekil 1.1 Konfigürasyonunu gerçekleştireceğim network topolojisi

Şekil 1.2 Router 0 ‘ın konfigürasyonu

İp yapılandırılmasının yapılandırıldığını varsayarak konfigürasyonu yapılandıralım

Router>enable

Router#configure  terminal

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.0

Router(config-router)#network 172.16.0.0

Şekil 1.3 Router 1 ‘in konfigürasyonu

Router>enable

Router#configure  terminal

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.0

Şekil 1.4 Router 2 ‘nin konfigürasyonu

Router>enable

Router#configure  terminal

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network 10.0.0.0

Router(config-router)#network 192.168.1.0

 

İle konfigürasyonumuzu sonlandırırız.

Şekil 1.5 Show ip route  komut ile de router’ın rip protokolü ile hangi networkleri öğrendiği görülür.

Bu konuyla ilgili sorularınızı https://forum.mshowto.org linkini kullanarak ulaşacağınız forum sayfamızda sorabilirsiniz.

Referanslar

https://www.mshowto.org

Yorum Yap

Yazar Hakkında

Neslihan Türkeri, İstanbul doğumluyum. Üniversiteye kadar olan eğitimimi İstanbul'da tamamladım. Kocaeli Üniversitesi Fizik bölümü öğrencisiyken sektörde çeşitli firmalarda çalıştım. Üniversiteyi bitirdikten sonra sistem ve network eğitimi aldım ve bilişimle ilgili şirketlerde çalıştıktan sonra Türkiye'nin en iyi bilişim kurumu olan Bilgeadam'da eğitmenlik yapmaktayım. Verdiğim Eğitimler -Bilgisayar Mimarisi ve Ağ Teknolojileri Temelleri -Bilgisayar Yönetimi ve Kullanıcı Desteği -Sunucu Sistemleri Yapılandırma -Sunucu Sistemleri Yönetimi -HP Sunucu Teknolojileri ve Yönetimi -Cisco Ağ Teknolojileri -Microsoft Exchange Server Yönetimi -Microsoft ISA Server Yönetimi Verdiğim Seminerler Windows Small Business Server Ailesi Windows Home Server Internet Information Services 7.5 Windows PowerShell 2.0

Yorum Yap

Yorumlar (3)

  1. Elinize sağlık güzel bir çalışma olmuş.

  2. 7 sene önce

    Hocam çok yararlı bir makale olmuş emeğinize sağlık….

  3. neslihan hocam güzel anlatmışsınızda biraz basit kalmış Rip ilgili biraz güncel bir makale yazabilirmisiniz