1. Ana Sayfa
  2. Exchange Server 2010
  3. Exchange 2003 Exchange 2010 CoExistence Transition (Birlikte Çalışma Durumu) – Sorun Çözümü – Bölüm 1

Exchange 2003 Exchange 2010 CoExistence Transition (Birlikte Çalışma Durumu) – Sorun Çözümü – Bölüm 1

Bugün yaşadığım bir deneyimi paylaşmak istiyorum. Öncelikle yapıyı anlatayım; bir tane AD forest’ım mevcuttu. Forest’ın isminin nwtraders.msft olduğunu varsayın. Altında fazlaca site mevcuttu. Ayrıca nwtraders.msft forest’ı altında 10 kadar child domain vardı. Bu yapıda halen hizmet vermekte olan 8 adet 2003 çalıştıran bir adet Exchange organizasyonu vardı. ’lardan 1 tanesi Front End Server olarak kullanılıyordu. Ve bu front end Server smart host tanımlaması ile email’leri bir başka stmp gateway’e aktarıyordu. (av/as amaçlı)Yapıya, 2010’a transition amacıyla 2 adet üzerinde cas kurulu (cas array haline getirilmiş nlb ile) ve hub kurulu sunucular eklenmiş. 4 adet dag olması düşünülerek mailbox Server eklenmiş. 2 adet Edge Server olması düşünülen sunucu eklenmiş.

CAS için http to https redirection yapılmış. Exchange Server 2003’ten test amaçlı bir kaç mailbox 2010’a aktarılmış ve Exchange Server 2010 MBX sunucularda barınan birkaç mailbox oluşturulmuş. Problem bana geldiğinde sorunlar şu şekildeydi.

1-) OWA için http://mail.nwtraders.msft/ url’si kullanıldığında IIS’ten explorer’a, 403 permission hatası geliyordu. OWA için https://mail.nwtraders.msft/ url’si kullanıldığında cas array düzgün çalışıyordu.

2-) Exhange Server 2003’te barınan mailbox kullanıcıları ile Exchange Server 2010 içinde barınan mailbox kullanıcıları birbirlerine mail atamıyorlardı. Ayrıca Exchange Server 2010 içinde mailbox’ı barınan kullanıcılar birbirleri ile de email alışverişinde bulunamıyordu.

1. Sorunun çözümü kolay oldu. CAS üyelerindeki IIS/Default Web Site/SSL Settings altındaki Require SSL check box’ını temizlemek yetti.

2. Sorun hayli yordu beni. Email alışverişi sorunu gözlemek amacıyla EMC’den Queue Viewer’ı açtım. Transport Server’a.Servise bağlanamadığı bildiren bir hata verdi. Servisler konsolunu açtım . Hub kurulu bu sunucuda transport Server kurulumu ile gelmesi gereken hiç bir servis(MS Exchange Transport vs…) yoktu. Ardında Registery’i inceledim. Exchange klasörü altındaki v14 klasörü altında HubTransport‘a dair hiç bir kayıt (subkey,dword,subfolder vs…) yoktu. Exchange Server 2010 kurulum klasörüne baktım. Hub Rolüne dair kayıtlar (agent.config vs…) tamamen bozulmuştu ve olanlar da eksikti. Hub Rolünü program ekle/kaldır’dan kaldırmak istediğimde yapının bozukluğundan dolayı hatalar aldım. Exchange Server 2010 setup’ını çalıştırıp maintenance mode’unda birşeyler yapmak istedim. Kurulum sihirbazında CAS ve HUB rolü kurulu görünüyordu ve kutuların check’leri pasifti. Temizlenemiyordu. Dolayısıyla bozuk olan hub mekanizmasını yeniden de kuramıyordum yada silemiyordum.

Zaman içinde google technet ikilisinde debelendikten sonra çözümü elde edebildim.

Adsiedit.msc ile configuration bölümüne bağlandım. Servisler altındaki Exchange organizasyonu altındaki Exchange Server objesinin özelliklerindeki bir attribute sayesinde; Exchange Server üzerinde hangi rollerin yüklü olduğunu algılıyordu.
Bu attribute’unun ismi msExchCurrentServerRoles ‘dır.

Resim-1

Attribute’un değeri, olan rollere göre sayıların toplamı şeklinde. Bendeki sunucular kendilerinde CAS ve HUB kurulu olduğunu düşündüğünden attribute’un değeri 36 idi. Değeri 4 yaptım. Çünkü düzgün olarak yüklü olan CAS idi. Sunucuyu yeniden başlattım. Exchange Server 2010 setup’ını tekrar başlattım. Artık maintenance mode’daki kurulum sihirbazında sadece cas rolü listeleniyordu. Hub rolü seçip devam ettim ve başarıyla kurulum tamamlandı.
Aynı işlemi diğer CAS+HUB ikilisi için yaptım. Sonuçta her ikli hub’da olması gerektiği gibi çalışmaya başladı. Kontrol amaçlı aşağıdaki ( daha önce kontrol edipte bozuk olan kısımları ) inceledim.

Herşey olması gerektiği gibiydi.


Resim-2

Yapının bozuk halinde bu dizinde agents klasörü haricinde hiç bir klasör yoktu. Agent.Conf dosyasının da içi boştu.


Resim-3

Üstteki taradığım hiç bir değer/klasör yoktu.


Resim-4

İlgili attribute’u test lablarımdan birinden örneklendirme amaçlı aldım. Bu değer bozuk olan yapıda 36 idi .{ 4 (cas) + 32 (hub) } Özetle bu değeri 4 yapmak benim için çözüm oldu.

Bu konuyla ilgili sorularınızı https://forum.mshowto.org linkini kullanarak ulaşacağınız forum sayfamızda sorabilirsiniz.

Referanslar

www.mshowto.org

Yorum Yap

Yazar Hakkında

1981'de Isparta’da doğdum. Üniversiteye kadar yaşantım Isparta'da devam etti. Lisansımı ve Yüksek Lisansımı Yıldız Teknik Üniversitesinde tamamladım. Windows NT'nin zamanının geçip Windows 2000 Server ve Client tarafının yaygınlaşmaya başladığı dönemlerde Microsoft sertifikasyon eğitimleri ile amatörce ilgilendiğim Bilişim Teknolojileri alanında, profesyonelliğe doğru ilerleyişim başladı. Lisans eğitimimin son zamanlarında ve yüksek lisansım ilk yılında freelance olarak çalıştım. 2006'in ilk çeyreğinden itibaren Bilge Adam Bilgi Teknolojileri Akademisi’nde Microsoft Sertifikasyon eğitimleri vermeye bağladım. Ardından Ankara Kızılay şubesinde 2 yıl Sistem ve Ağ Uzmanlığı departmanında Bölüm Başkan Yardımcılığı yaptım. Bilge Adam Kurumsal’da MS Sistem ve Platform kısmında Danışmanlık ve Eğitim hizmetleri ile Bilge Adam macerama devam ettim. Son 1.5 yıl kurumum adına Savunma Teknolojileri Mühendisliği A.Ş. 'ye MS Sistem ve Platform, Vmware Infrastructure (ESXi, vSphere) , Endpoint Security & Content Gateways (Checkpoint & Websense) , Network Infrastructure (Cisco Systems - Routing & Switching) alanlarında danışmanlık hizmeti verdim. Şu an SYMTURK firmasında Enterprise Vault ve Altiris CMS ürünlerinde danışmanlık hizmetine devam ediyorum. Vakit ayırabildiğim ölçüde eşimle WoW oynuyorum.

Yorum Yap